3.0.5

Grid within Grid does not display properly in Mozilla-like browsers


I am back to the web work that was abandoned a few months back.
When I last was doing this work I created a way to expand a row to show details. At that time my example showed simple text as the details. I am now trying to display a grid that contains the details for a row. In I.E. it works just fine BUT in the "Mozilla and the like") browsers when I display a grid within a grid I get just one row of data, even when there should be multiple rows. The odd thing here is that I see numbered rows, but all of the data appears horizonally in the first row.

If I remove the patch that allows grid lines to be shown in the mozilla browsers when I scroll to the right then the problem I explain above goes away BUT the grid line problem comes back.

Is there something I can do to fix both ?

Here is an example: http://www.secretagentsband.com/aw/examples/grid/testRowExpansion.html

Frank Gualtieri
Frank Gualtieri
July 14,
oops.. I forgot to inform you that to see the grid within the grid you need to click on a row.

ALSO - again, this problem only occurs in the mozilla browsers when the patch:

.active-templates-row.gecko {
display: -moz-box;
width: auto;
min-width: 100%;
}

is applied.
Frank Gualtieri
July 14,
As a workaround I found that this problem goes away if you wrap the inner grid in a table.

I.E. <table><tr><td>the grid widget</td></tr></table>
Frank Gualtieri
July 14,
For me in mozilla, it works fine but not in IE
s_r
July 14,

This topic is archived.

See also:


Back to support forum